PDA

View Full Version : Lock pick problems


T-pole
02-14-2009, 06:43 PM
Anyone having an issue with their Coastaletech lockpick?

The guys at CoastalETech are cool, and trying to help. They say it's an issue with the new Nav CD Ver 4.0c

The strange thing is, this is the CD that came with my truck. But, they said that it can take a couple months for error codes to pop up and affect the lockpick. I've had it installed for almost 3 months.

The issues are that my mute button doesn't activate the lockpick, but does make the 'beep' like it is working.

Also, even when I don't activate the lockpick, the Nav doesn't give me turn by turn or voice prompt directions, but it does show the car moving down the street.

Carlos at CoastalETech said to give him a couple weeks to order the new version of the CD and get the issues sorted out.

colemans07tahoe
02-15-2009, 10:01 AM
HMM? My lockpick should be in Monday of next week. I will let you know it I have the same problems. I also have the old version disc as well, so I guess if I am having problems I could just install it, huh? Keep us posted what you find out and I will let you know what happens with me.

ibobby
02-15-2009, 03:19 PM
man.. I logged on just to re-read some of the posts about the Lockpick. I wanted to order one today and hoped to get it in by this Friday. I too have the latest Nav Disc (4.0c) for my 07 Denali.

I also didnt know which one to get. Coastal $250 or the other company for $199.

T-pole
02-15-2009, 04:48 PM
man.. I logged on just to re-read some of the posts about the Lockpick. I wanted to order one today and hoped to get it in by this Friday.

From Mid November till about a week ago, my Lockpick has been great!

Definitely not trying to discourage anyone from getting one. The guys at CoastalETech are great too. They said that they've only heard of one other occurrence like mine.

They said that they'll do whatever they have to, to fix the problem.

Let us know which one you decide on, and I'll update you when I hear back from the lock pick guys.

ibobby
02-15-2009, 08:24 PM
Thanks man. There are others that have the 4.0c disc and I believe its working with no problems.

I'm really not sure which one to get. I like to save $50, but don't know it will work the same or be the same quality.

randyp
02-16-2009, 02:43 PM
I've experienced a few issues.

1) Sometimes, the NAV no longer works. It 'freezes' the location and does not track my progress.
I know this is how the device works when engaged either by pressing the mute button and/or the door lock button. This occurs when the vehicle is started.
This seems to occur for a day or two and then disappears only to reappear after several weeks.
Loose wiring harness??

2) I experienced extreme static with Onstar when the vehicle was in motion. When stopped I could have a normal conversation but while driving no way.

I took the vehicle into the dealership (for other issues) and decided to remove the Lockpick so I wouldn't have warranty problems. The Onstar issue disappeared. Now I'm wondering if I want to put the lockpick back in again.

Also, I purchased the Scosche IPOD device but never got it working. After working with Schoshe and getting three different units shipped to me it never did work. It wouldn't load up the MP3 songs on the NAV unit.

Now, I'm wondering if the Lockpick was causing the problem with the Scosche unit. I'll have to try it again.

While these devices are certainly cool and I love their functionality, I hate to spend a bunch of time trying to get them to operate properly. :(

ibobby
02-25-2009, 10:31 PM
any updates? anyone else hear of this problem?

T-pole
02-26-2009, 06:58 PM
Not yet. I had to make a copy of my Nav disc and send it to him for testing purposes. I should hear something back in the next week or 2