PDA

View Full Version : 2005 Tahoe Rear Heat Issue


sutphen1
11-08-2012, 08:18 AM
Hello, I am having an issue with my rear heat on my 2005 Tahoe 5.3 LS. I have the issue of "unable to control rear HVAC temp". The mode setting for air circulation works fine. The speed adjustment for the blower works fine. The warm to cool adjusment wont change at all. Currently the system is stuck in the cold position. I hooked into my friends system (he has an actual system hat can diagnose and reflash my truck) And it provided the bulliten to repair DTC B0434. The worksheet advised to replace the temp control module and I did. We had checked the temp door itself and it moves just fine...the actuator is getting power and I even went as far as to by a new ACDelco Actuator and tried a install and reflash with no luck. Everything has power as it should and volts seem to be ok. My friend can actually make the actuator work with his system and reset the paramiters for travel but as soon as the system resets the code B0434 comes back and the warm and cold function wont respond. This has been tricky for me to say the least..I am bald and have no hair to pull out..I dont want to resort to head bashing on my wall...Any help would be great. Thanks a bunch!:whymewhyme:

rcccm
01-05-2013, 07:04 PM
Not sure if you have gotten this fixed or not yet, but I had the same issue with our '05 Tahoe. I replaced the Control Module Kit, AC Delco Part# 15832319 and it fixed the issue. Hope this helps.

Grebbler
01-08-2013, 04:13 AM
There should also be a blend door and motor back there. The actuator motors go bad, also.