Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Register to remove these ads.
General Tahoe/Yukon/Escalade Discussion Forum General Tahoe/Yukon/Escalade Discussion Forum



Reply
 
Thread Tools Display Modes
Old 08-07-2017, 01:59 PM   #341
hcauto74
Tahoeforum Newcomer
 
Join Date: Aug 2017
Age: 19
Posts: 2
hcauto74 is on a distinguished road
Default Bull bar need help!!

I have a 1999 Tahoe LT 4x4 . I've been looking for quite sometime for a chrome bull bar thats cheap. It's not very hard to find a cheap black one but i need help finding a chrome one under $200
hcauto74 is offline   Reply With Quote
Old 08-21-2017, 04:14 PM   #342
CaptainEgg
Tahoeforum Newcomer
 
Join Date: Jul 2012
Location: Akron, Ohio
Posts: 3
CaptainEgg is on a distinguished road
Default Miles

I have 207,750 on a 2004 that I bought new.
CaptainEgg is offline   Reply With Quote
Old 08-23-2017, 12:17 PM   #343
WarrenH
Tahoeforum Newcomer
 
Join Date: Jun 2014
Posts: 7
WarrenH is on a distinguished road
Default

2004 Chevy Tahoe 5.3 FF

207,000+
WarrenH is offline   Reply With Quote
Old 08-26-2017, 07:45 PM   #344
JAWZ
Tahoeforum Newcomer
 
Join Date: Aug 2017
Posts: 3
JAWZ is on a distinguished road
Default

I would wager that I have the least miles on the oldest Tahoe. I inherited my 1999 Tahoe LT 4dr 2wd about 3 years ago. When I left TX for VA in April of 2014, it had ~23,000 miles on it. It currently has about 45,000 miles on it. It's made one trip back to TX from VA and one trip to OH and back to VA.
JAWZ is offline   Reply With Quote
Old 10-23-2017, 05:21 PM   #345
scorpio
Tahoeforum Apprentice Member
 
scorpio's Avatar
 
Join Date: Nov 2007
Posts: 46
scorpio is on a distinguished road
Default

2003 LT 5.3 186k
scorpio is offline   Reply With Quote
Old 11-17-2017, 06:03 PM   #346
dmad1
Tahoeforum Newcomer
 
Join Date: May 2017
Posts: 9
dmad1 is on a distinguished road
Default

'12 LT 2 wheel drive with 93k. Changed tranny fluid in pan with filter at 85k. Still looked dirty, so recently did a flush with 10 quarts. Easy to flush. Don't pay to have it done. Paid $200 for first change at 85k but they couldn't get the pan off without dropping the exhaust so they skipped that but was able to reach in and change the filter. The fluid still looked a little brown, so did the flush myself. Pretty pink now. Was not having problems with tranny but figured it was on borrowed time.
For several months now, it seemed to be sluggish and didn't accelerate like I felt it should. Figured it might be an injector problem so I ran some Chevron Techron through it two times with no change and them the same with Sea Foam. Read an article on an injector cleaner from Amsoil called Pi. After two tanks of fuel, it runs like it's supposed to. Good stuff. Other than that, it has never been to a shop except or oil changes. The second tire change, I put on Cooper Mastercraft 10 ply tires and love them. Can't tell that it hurt the ride at all. Hoping to get many, many more miles out of it even though the wife wants a new one.
dmad1 is offline   Reply With Quote
Old 11-20-2017, 01:13 AM   #347
ssglaird
Tahoeforum Newcomer
 
ssglaird's Avatar
 
Join Date: Sep 2016
Location: Southern Missouri
Posts: 6
ssglaird is on a distinguished road
Default

1995 Tahoe with 330,000. Factory engine, new tranny and transfer case.
ssglaird is offline   Reply With Quote
Old 02-04-2018, 04:25 PM   #348
bill77056
Tahoeforum Newcomer
 
Join Date: May 2013
Location: Houston, TX
Posts: 9
bill77056 is on a distinguished road
Default

Quote:
Originally Posted by bill77056 View Post
Repair History 2005 Tahoe 4X4 Z71 In-Service 1/5/05

This is an update to 130.9k miles; 2/2/18

Repl SDM Module
Reprogram Power Control Engine; Install Exhaust Vibration Damper
Repl Intermediate Steering Shaft and Fuel Level Sensor
Repl Transfer Case Actuator
Repl: L Temp Valve Actuator, Pwr Brake Booster, RR Window Regulator
Repl LR TPMS Sensor
Repl: HVAC Control, R Temp Valve Actuator, Steering Shaft
Repl Lower Column Bearing and L Temp Valve Actuator
Repl Blower Motor Resistor
Repl High Mounted LED Brake Light
Repl Transfer Case Encoder Motor Sensor
Repl All (7) Instrument Cluster Stepper Motors
Repl Canister Vent valve (104.1k mi)
Repl Purge Solenoid
Repl water pump (106.3k mi)
Repl right outside mirror lamp
Repl driver side seat and arm rest covers (114k mi)
Repl rear window lift supports
Repl rear brakes and rotors, AC blower motor, left temp. actuator, instrument panel rheostat (118.8k mi)
Remove gas tank; Repl vapor canister, fuel lines, vent solenoid and fuel pump (121.3k mi)
NOTE: one might consider preventive maintenance to change charcoal vapor canister ~100k mi
Replace front bulbs: Sidemarker (2), DRL (2) DIY cost $14 (123.1 mi)
Recover headliner
Replace starter motor
bill77056 is offline   Reply With Quote
Old 03-15-2018, 02:01 PM   #349
shane.nelson
Tahoeforum Newcomer
 
Join Date: Mar 2018
Location: Kannapolis, NC
Posts: 2
shane.nelson is on a distinguished road
Default

--------------------------------------------------------------------------------
1999 Chevy Tahoe LT 4x4
160,000 miles

So I'm having a vibration issue on my Tahoe. I've done a lot, and I mean a lot to try and solve the problem. This is just a list of what I've done.
-Rebuilt Front and Rear diff.
-Rebuilt transfer case
-Rear drive shaft re-balanced with new slip yoke and u-joints
-New front axel half shafts
-New front wheel hub assemblies
-New 265-70-18 AT Tires on GM wheels off of a 2010 Tahoe
-New upper and lower ball joints
-New(ish) shocks all the way around
Any idea what else it could be? I didn't mind spending the money on these things, even if it didn't fix the problem. I plan on keeping the Tahoe for a long time. However this vibration at 65+ mph is getting annoying. The steering could be tighter to be honest. I kinda thought motor mounts as well. They are original with 160k on the clock. Idler and pitman arm are original as well.
shane.nelson is offline   Reply With Quote
Old 03-15-2018, 02:47 PM   #350
dmad1
Tahoeforum Newcomer
 
Join Date: May 2017
Posts: 9
dmad1 is on a distinguished road
Default

Not sure if you did this or not. Jack up the front. Grab the tire with one hand on top and the other under it and see if you make move it up and down. If so adjust the movement out of the bearing. Also, I recently viewed a '14 Silverado video of it on the rack and they were checking for drive shaft run out. It also looked as if the carrier bearing was wobbling. Just guessing.
dmad1 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum