Go Back   Tahoe Forum - Chevy Tahoe Forum > 2015 + Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Register to remove these ads.
General Tahoe/Yukon/Escalade Discussion Forum General Discussion Forum



Reply
 
Thread Tools Display Modes
Old 06-23-2016, 04:34 PM   #11
69meano
Tahoeforum Newcomer
 
Join Date: Jun 2016
Posts: 8
69meano is on a distinguished road
Default

It is a lean condition at idle -no fix yet...have had all done as everyone has stated
69meano is offline   Reply With Quote
Old 06-24-2016, 12:17 PM   #12
Margusm
Tahoeforum Newcomer
 
Join Date: Apr 2016
Posts: 6
Margusm is on a distinguished road
Default Time for lemon lawsuit

Unless we get organized and complain in large numbers GMC / Chevy WILL NOT bother to fix it. I was told so by technician at one of the most prestigious store in Central Florida.

I have a lemon lawyer if anyone else wants to join me. We need to organize a mass complaint to fix this.

I DO NOT WANT TO BE STUCK WITH $50K+ VEHICLE WHICH DOES NOT RUN CORRECTLY!!

I will create a Facebook page where people can submit their complaints. Making noise is only way to fix this issue!
Margusm is offline   Reply With Quote
Old 08-24-2016, 06:44 PM   #13
MGHick007
Tahoeforum Newcomer
 
Join Date: Aug 2016
Posts: 2
MGHick007 is on a distinguished road
Default

Count me in. New to the forum but in the same boat. My wife drives our 2015 Tahoe LT "Texas Edition". Just had it serviced for the 4th time and no change. The 3rd time they just shimmed the mounts which is obviously easier for the tech than installing new mounts all together. On this fourth attempt, the Service rep told me they installed the new style mounts. Immediately got in and noticed less shake in drive but still some however, it now shakes more while in Park and neutral which it did not do before. Wife is extremely frustrated, as am I. Also, side trim panels between front/rear doors (Windows) on both sides would flap like crazy at highway speed but they fixed that on visit 3 (probably just squirted apoxy or adhesive in behind them). Finally, we reported on visit #2 (along with idle issue again) that the rubber (accordion looking) side guide seals for the sun roof were not staying in place when attempting to close. They would shift around and get pinched when closing. They fixed them to stay in place but now we have a leak each time there is a heavy rain and it starts dripping slowly out of the passenger sun visor bracket once you get in and start driving. Can you believe it!? Unbelievable! Researching now for what legal recourse we may have.
MGHick007 is offline   Reply With Quote
Old 08-24-2016, 06:50 PM   #14
MGHick007
Tahoeforum Newcomer
 
Join Date: Aug 2016
Posts: 2
MGHick007 is on a distinguished road
Default

Forgot to include your quote before my recent reply post so check it out when possible.
MGHick007 is offline   Reply With Quote
Old 04-06-2018, 02:16 AM   #15
rhellesoe
Tahoeforum Newcomer
 
Join Date: Apr 2018
Posts: 1
rhellesoe is on a distinguished road
Default

Any leads to the issue with the rough idle? I just came across the thread.
rhellesoe is offline   Reply With Quote
Old 04-06-2018, 11:39 AM   #16
69meano
Tahoeforum Newcomer
 
Join Date: Jun 2016
Posts: 8
69meano is on a distinguished road
Default

Had the mounts shimmed and induction cleaning(i did) and rough idle went away and has not come back since.
69meano is offline   Reply With Quote
Old 11-18-2018, 05:52 PM   #17
Jcorr
Tahoeforum Newcomer
 
Join Date: Nov 2018
Posts: 1
Jcorr is on a distinguished road
Default

2016 here same issue. They are running idle rpm to low because of EPA . GM will never raise it. Get an independent shop to bump it up above 550 600 and it will be better
Jcorr is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 03:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum