Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Register to remove these ads.
Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 12-08-2018, 01:19 PM   #1
Whitelx1
Tahoeforum Newcomer
 
Join Date: Dec 2018
Posts: 1
Whitelx1 is on a distinguished road
Default HVAC stuck in default mode(defrost only )

What started off as my heat only blowing on the face vents, now the system is in default.
I replaced the mode actuator with a GM one and tried to calibrate it and after installation it only goes to defrost.
I thought it might be a bad control panel bought one and now when you plug the new one in, it cycles thru all the cycles and Then goes on back to default.
At first I was getting a BCM code of a aspritator only to find out mine was unplugged. I plug it in and now the code is gone but still only defrost...
Has anyone experienced this before. I am completely lost right now and I even had a friend from Chevy look at it on a GM scanner. He manually opened all the blend doors and when you shut the truck off back into default...

Last edited by Whitelx1; 12-10-2018 at 03:19 AM.
Whitelx1 is offline   Reply With Quote
Old 02-03-2019, 01:27 AM   #2
RobbysDad
Tahoeforum Apprentice Member
 
Join Date: Feb 2019
Posts: 17
RobbysDad is on a distinguished road
Default

I think you are on the right track with the blend actuator. I have a 2005 and their are 3 of them in the front and one in the rear under the right side cargo compartment under the rear side glass with me having that tri-cooling or whatever they called it. I have an LT with the digital display, but think it applies to all of them and a little searching will tell you.

Did you hear any clicking or do you?

Which one did you change? Their is one right under the center console that with the tri-cool decides what temperature each side gets. When that goes bad it is havoc one side hot, one side cold, no rhyme or reason. Turn off the truck and it could reset and be all good or not. Then their is one I believe which could be your problem that you have to take everything out of the glove box and push in on the plastic on it so it drops down all the way. That one I believe controls where it is sending the air. Like you said defrost going high, vents, or bottom.

The other one I have never changed and heard it is a pain due to you have to pull the dash on drivers side and that one I think controls air speed. I never changed one of those, but recall hearing it is there.

Main think is they click when they go bad and then at first they have a mind of their own with what they want to do. This is very important. They all look identical and all have their own p/n and are not interchangeable. I have heard people change it and have problems still, but problem is they got the wrong one.

Did it do weird things when it first happened not blowing where you wanted it? Clicking? Plus, if you changed that did you get the p/n off the old and get the right one? Post on here or message me I have worked on this a lot.
RobbysDad is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 09:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum