Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 08-16-2008, 09:15 AM   #1
gary sutphin
Tahoeforum Noob
 
Join Date: Aug 2008
Posts: 4
gary sutphin is on a distinguished road
Default 2006 Tahoe Oil Pressure


Register to remove these ads. It's free!
On a trip yesterday, my low oil pressure message warning came on as well as service engine light. I checked and realized I was low on oil. Noproblem coming home after that except service engine light still on. This morning, oil pressure warning came back on and I have oil. Is there any correlation between the service engine warning and the low oil pressure problem? I'm worried about the low oil pressure warning and I'm not very good at figuring out car problems.
gary sutphin is offline   Reply With Quote
Old 08-16-2008, 12:42 PM   #2
rjardy
Tahoeforum Apprentice Member
 
Join Date: Jul 2008
Posts: 18
rjardy is on a distinguished road
Default

hard to tell. How low were you on oil? You would normally have to be pretty low. The oil pump has a picku-up that sticks down into the oil pan to bring oil through the motor. Usually the only way your pressure goes away is if that pick-up is not covered in oil. Hopefully you didnt damage your engine by running it low on oil.

As for the CEL, you will have to pull the code to see if it is related.
rjardy is offline   Reply With Quote
Old 08-16-2008, 12:49 PM   #3
M.M. 700
Full Access Member
 
Join Date: Jul 2008
Posts: 87
M.M. 700 is on a distinguished road
Default

What was/is your oil PSI guage reading??
Are you sure its not a low oil LEVEL alarm?
M.M. 700 is offline   Reply With Quote
Old 08-16-2008, 08:44 PM   #4
gary sutphin
Tahoeforum Noob
 
Join Date: Aug 2008
Posts: 4
gary sutphin is on a distinguished road
Default

Quote:
Originally Posted by M.M. 700 View Post
What was/is your oil PSI guage reading??
Are you sure its not a low oil LEVEL alarm?
Thanks for your help. I did have a little oil on the dipstick. It was definitely the low pressure indicator as I've never experienced that before. As mentioned, it did it again early this morning, but not since, althought the CEL is still on. Waiting to talk to the dealer on Mondat, gut was hoping to find a clue before.
gary sutphin is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum