Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


General Tahoe/Yukon/Escalade Discussion Forum General Tahoe/Yukon/Escalade Discussion Forum



Reply
 
Thread Tools Display Modes
Old 01-18-2009, 10:11 AM   #1
joshposh007
Tahoeforum Noob
 
Join Date: Jan 2009
Location: Toronto
Age: 51
Posts: 2
joshposh007 is on a distinguished road
Default Stability System Disabled ????


Register to remove these ads. It's free!
I've got a '05 4WD Tahoe LS with 88,000 kms. Recently when I started the truck, the LED display in the dash says "STABILITY SYS DISABLED" and the 4WD indicator light on the left hand side of the dash says the vehicle is in 4WD Low, after me shutting the vehicle down in 2WD previously. I've tried to switch back into 2WD, but the light just blinks for awhile, then stops. It does not go back to 2WD. It doesn't feel like the engine is in 4WD, but it's concerning none the less.

The engine also acts very sluggish when this "STABILITY SYS DISABLED" message is displayed.

I read in some forum to do the following to put it back to 2WD.
*** Make sure your vehicle is in Neutral when trying to return to 2WD from 4WD Low.

I did as instructed and it seemed to work. Does anybody know if this is a serious problem that I need to have a mechanic run some test on it? Doe s anybody know what this symptom is & point me at the right direction to have it fixed? I'd rather not take it to a dealer right away, does anyone have any ideas what could be wrong?

Any help would be greatly appreciated.
joshposh007 is offline   Reply With Quote
Old 01-18-2009, 11:01 AM   #2
brodg
Full Access Member
 
Join Date: Nov 2007
Posts: 110
brodg is on a distinguished road
Default

unfortunatly there are too many components to guess at without a code. if you can pull a code it will help try auto zone for a free code scan or go to the dealer and slide a tech 20 to do it. then come back and i can help.
brodg is offline   Reply With Quote
Old 01-18-2009, 11:13 AM   #3
joshposh007
Tahoeforum Noob
 
Join Date: Jan 2009
Location: Toronto
Age: 51
Posts: 2
joshposh007 is on a distinguished road
Default Stability System Disabled????

Brodg,

Thank you for replying. Sorry for being so ignorant about this, but what code are you referring to specifically.

Is this something I can find in the vehicle manual?

Thanks again.
joshposh007 is offline   Reply With Quote
Old 01-18-2009, 11:44 AM   #4
Rivieraracing
Full Access Member
 
Join Date: Feb 2008
Location: Oregon
Posts: 277
Rivieraracing is on a distinguished road
Default

Your computer might be sensing that something is wrong, therefore it will produce a "code" that can only be retrieved by hooking up a scanner device to the computer plug-in port. By doing this will help narrow down the search of the problem, if there is even a code present at the computer at all.
Rivieraracing is offline   Reply With Quote
Old 01-18-2009, 12:31 PM   #5
brodg
Full Access Member
 
Join Date: Nov 2007
Posts: 110
brodg is on a distinguished road
Default

it would be a code pulled with a scanner the module it will be in is called the rtd module i don't think auto zone will be able to retrieve it only a gm tech 2 can monitor this module.
brodg is offline   Reply With Quote
Old 01-18-2009, 01:17 PM   #6
Rollin Thunder
Full Access Member
 
Rollin Thunder's Avatar
 
Join Date: Aug 2007
Location: Va, beach, va
Age: 27
Posts: 6,476
Rollin Thunder is on a distinguished road
Default

when ever the vehicle is put in 4lo, it disables the stability system. So its not your stability system, its your 4x4 system. Your engine will feel sluggish in 4lo and you should not go above 25 mph in 4 lo. It could be as simple as a switch, or super complicated.
Rollin Thunder is offline   Reply With Quote
Old 01-19-2009, 11:05 AM   #7
RIDE N FLY
Full Access Member
 
RIDE N FLY's Avatar
 
Join Date: Mar 2008
Location: Laplace, La
Posts: 50
RIDE N FLY is on a distinguished road
Default

i have an 05 and i have the same problem except mine comes on while i'm driving, but it is still in 2wd mode. It doesn't drive any differently, its just annoying to see it come on and not know why. If anyone finds a solution that would be great.
RIDE N FLY is offline   Reply With Quote
Old 09-02-2011, 02:38 PM   #8
gasser76
Tahoeforum Noob
 
Join Date: Sep 2011
Posts: 3
gasser76 is on a distinguished road
Default

RIDE N FLY,

Where you able to figure out your problem? I have the exact same issue. No other errors messages or codes. Just the "Stability System Disabled" while in 2wd. It flashes quite often.
gasser76 is offline   Reply With Quote
Old 09-10-2011, 12:49 AM   #9
Spartus
Tahoeforum Newcomer
 
Join Date: Aug 2008
Posts: 5
Spartus is on a distinguished road
Default

my 2003 Sierra did that same thing. They replaced the 4wd selector switch on the dash and reflashed the pcm at the dealer.. Problem fixed. My cruise control wouldn't work either, but since it thought I was in 4wd-lo then I don't blame it.
Spartus is offline   Reply With Quote
Old 07-03-2013, 10:14 PM   #10
ZombCJ
Tahoeforum Newcomer
 
Join Date: Jul 2013
Posts: 6
ZombCJ is on a distinguished road
Default


Register to remove these ads. It's free!
I am having a similar problem with my 2006 4wd Tahoe right now. At first the stability system disabled message would flash. Usually after turning the truck off or driving it for a short distance the message would go off. After about 2 months it started staying on all the time. Now I am also getting a service 4wd message. The switch on the dash sometimes shows awd and sometimes shows 2wd, but it won't change if you press any of the buttons. I have an appt at the dealer this Friday. I will post what I find out. In the meantime I may take it to autozone just to see if they can plug in a diagnostic check and give me an error code.
ZombCJ is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 07:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum