Go Back   Tahoe Forum - Chevy Tahoe Forum > 2007 + Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


General Tahoe/Yukon/Escalade Discussion Forum General Discussion Forum



Reply
 
Thread Tools Display Modes
Old 02-27-2012, 02:14 AM   #1
elrey7698
Tahoeforum Newcomer
 
Join Date: Feb 2012
Posts: 5
elrey7698 is on a distinguished road
Default tahoe dash problem


Register to remove these ads. It's free!
so in the attemp of swapping headunits i lost most of the lights in my truck. i have an 07 tahoe ls. the traction control shuts off but the light does not appear on my hud. also the towing light wont come on and the compass and thermometer are completely off..im sure its a fuse but which one? i cvant read the diagram on the fuse cover...please help a new member out...
elrey7698 is offline   Reply With Quote
Old 02-27-2012, 08:59 AM   #2
clkelley
Super Moderator
 
clkelley's Avatar
 
Join Date: Jul 2011
Location: Galax, Virginia
Posts: 1,112
clkelley is on a distinguished road
Default

Welcome to the neighborhood!

It sounds like you blew an ignition fuse. Inside the dash fuse panel, pull the 10amp fuses first, there should be three to the left side of the fuse block, two about halfway up and side by side and one in the top left corner. See if that works.

Did you disconnect it? Figure out what may have caused the fuse to blow?
clkelley is offline   Reply With Quote
Old 02-27-2012, 09:39 PM   #3
elrey7698
Tahoeforum Newcomer
 
Join Date: Feb 2012
Posts: 5
elrey7698 is on a distinguished road
Default

I checked all the fuses on the dash fuse block...and non are blown
elrey7698 is offline   Reply With Quote
Old 02-28-2012, 08:22 PM   #4
clkelley
Super Moderator
 
clkelley's Avatar
 
Join Date: Jul 2011
Location: Galax, Virginia
Posts: 1,112
clkelley is on a distinguished road
Default

I honestly believe that you may have pulled a wire lose in the plug behind the hu, if not in the plug for the hu, then in one near it. I find it very easy to do that given how tight things are with the dash wiring. Did you take the hu back out and double check the wiring? Make sure you didn't pinch a wire causing a ground somewhere.
clkelley is offline   Reply With Quote
Old 02-29-2012, 05:47 AM   #5
elrey7698
Tahoeforum Newcomer
 
Join Date: Feb 2012
Posts: 5
elrey7698 is on a distinguished road
Default

I checked everything im just gonna wait till saturday and take apart the whole dash...i just saw that the original installer of my hu used one of the wires in that black box next to the brake as the stereos memory power source
elrey7698 is offline   Reply With Quote
Old 02-29-2012, 10:23 AM   #6
clkelley
Super Moderator
 
clkelley's Avatar
 
Join Date: Jul 2011
Location: Galax, Virginia
Posts: 1,112
clkelley is on a distinguished road
Default

I need to make a correction in what I said yesterday, that metal bracket is rivited, not bolted to that section of the dash, I have included a picture of the back view of it for you. Also, I have included pics and inctructions below for pulling the pins fro the pigtail connectors in there for you.

This is the pic of that bracket, if you are taking the dash apart and you take it this far you can cut that bracket or drill out the rivits and remove it altogether, but I personally would try to keep it intact so support. Try cutting the plastic first before you take the dash apart and check the fitting of the DDHU. This way you know before it comes out whether you want/need to cut/remove the metal bracket.


In that plug there are two "security" locking pieces that are suppose to help secure the wire/pins in the connector. Remove the blue and grey security lockers, and then once that is done you can use needlenose pliers to gently pull each pin from the connector. When replacing each one make sure that you get it fully seated into the connector.



This plug is to the climate control panel, you maay want to double check everything there as well since you are going to take the dash apart to find the issue. It doesn't have the security lockers so you don't have to worry about that.


Hope this helps a bit...
clkelley is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 07:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum