Go Back   Tahoe Forum - Chevy Tahoe Forum > 1994 - 1999 Chevrolet Tahoe/GMC Yukon Year Models > Technical Discussions

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 04-22-2012, 05:28 PM   #1
souperbee
Tahoeforum Newcomer
 
Join Date: Jan 2012
Posts: 4
souperbee is on a distinguished road
Default 97 Tahoe runs a couple of seconds and then dies


Register to remove these ads. It's free!
We are working on a 97 Tahoe 4wh dr. 5.7 vortec. This is what we have. BTW it has 230,000 miles on it. Check fuel psi. 58 to 62psi. Replaced fuel filter, (had small amount of water in it) Dropped tank and cleaned installed new fuel pump. First pump wouldn't even run. Return, 2nd pump runs 60 psi engine starts after 2 second prime then dies as if starving for fuel. spray fuel in throttle body and engine keeps running. Get another fuel pump and is doing the same thing. I don't think it can be 3 bad pumps although I've seen it happen. After 2 second prime engine starts and runs a few seconds, sounds real good then acts as if it is starving for fuel. take spray bottle of gas and it keeps running. The vehicle has new spark plugs, distributor, new fuel relay, fuel filter, blew out the fuel lines. 3 fuel pumps. Took intake and cleaned all the fuel lines and injectors, The only thing we didn't do is check the fuel regulator. How do you check the fuel regulator? Would this cause the problem? I am open for suggestions it is driving my neighbor crazy. What are we over looking. Btw did a vacuum test and it was good. No vacuum leaks. needle nice and steady. Suggestions?
souperbee is offline   Reply With Quote
Old 04-22-2012, 05:41 PM   #2
lesterl
Full Access Member
 
Join Date: Oct 2011
Location: MO
Posts: 1,757
lesterl is on a distinguished road
Default

With Pressure guage hooked up, observe the PSI for the fuel pressure when cranking and after it starts/ then dies.

Unplug the MAF sensor (the electrical pigtail), and retest. Ohm out the CTS sensor also.
lesterl is offline   Reply With Quote
Old 04-22-2012, 11:16 PM   #3
souperbee
Tahoeforum Newcomer
 
Join Date: Jan 2012
Posts: 4
souperbee is on a distinguished road
Default

lesterl........I want to thank you very much. The connection to the MAF sensor was bad .I can't believe something that simple gave us so much grief. Anyway Thank you very much once again.
-souperbee
souperbee is offline   Reply With Quote
Old 04-22-2012, 11:25 PM   #4
lesterl
Full Access Member
 
Join Date: Oct 2011
Location: MO
Posts: 1,757
lesterl is on a distinguished road
Default

It does tell the PCM how much air is comming in, it then calculates a fuel charge to go with the incoming air and injects it, if the MAF malfunctions or the like, then it thinks low/no air, and a corresponding ammount of air. The PCM ignores this input upon startup untill the signal stabilizes.... yours didnt, so it stopped the fuel flow. MAF can get dirty and cause fueling issues also.

Glad you gott'er going.....

BTW the ignition is almost standalone........
lesterl is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum