Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


General Tahoe/Yukon/Escalade Discussion Forum General Tahoe/Yukon/Escalade Discussion Forum



Reply
 
Thread Tools Display Modes
Old 11-08-2012, 09:18 AM   #1
sutphen1
Tahoeforum Newcomer
 
Join Date: Nov 2012
Posts: 2
sutphen1 is on a distinguished road
Default 2005 Tahoe Rear Heat Issue


Register to remove these ads. It's free!
Hello, I am having an issue with my rear heat on my 2005 Tahoe 5.3 LS. I have the issue of "unable to control rear HVAC temp". The mode setting for air circulation works fine. The speed adjustment for the blower works fine. The warm to cool adjusment wont change at all. Currently the system is stuck in the cold position. I hooked into my friends system (he has an actual system hat can diagnose and reflash my truck) And it provided the bulliten to repair DTC B0434. The worksheet advised to replace the temp control module and I did. We had checked the temp door itself and it moves just fine...the actuator is getting power and I even went as far as to by a new ACDelco Actuator and tried a install and reflash with no luck. Everything has power as it should and volts seem to be ok. My friend can actually make the actuator work with his system and reset the paramiters for travel but as soon as the system resets the code B0434 comes back and the warm and cold function wont respond. This has been tricky for me to say the least..I am bald and have no hair to pull out..I dont want to resort to head bashing on my wall...Any help would be great. Thanks a bunch!
sutphen1 is offline   Reply With Quote
Old 01-05-2013, 08:04 PM   #2
rcccm
Tahoeforum Newcomer
 
Join Date: Apr 2011
Posts: 2
rcccm is on a distinguished road
Default

Not sure if you have gotten this fixed or not yet, but I had the same issue with our '05 Tahoe. I replaced the Control Module Kit, AC Delco Part# 15832319 and it fixed the issue. Hope this helps.
rcccm is offline   Reply With Quote
Old 01-08-2013, 05:13 AM   #3
Grebbler
Full Access Member
 
Join Date: Oct 2008
Location: Detroit,MI
Posts: 95
Grebbler is on a distinguished road
Default

There should also be a blend door and motor back there. The actuator motors go bad, also.
Grebbler is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum