Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 03-01-2008, 12:57 PM   #1
Botches
Tahoeforum Apprentice Member
 
Botches's Avatar
 
Join Date: Feb 2008
Location: Arkansas
Posts: 18
Botches is on a distinguished road
Default lights flickering


Register to remove these ads. It's free!
Has anyone ever had any issues with the lights (interior/exterior) flickering? Someone told me once it was just as simple as a change in the connector to the alternator.
Botches is offline   Reply With Quote
Old 03-01-2008, 01:10 PM   #2
KillerB
Tahoeforum Apprentice Member
 
KillerB's Avatar
 
Join Date: Mar 2008
Location: Moore, SC
Posts: 36
KillerB is on a distinguished road
Default

Could be a loose connection to the alternator, or any other wiring points. Check as many as you can, including:
Battery terminals
Alternator terminals
Grounding straps

Could also be a bad dimmer switch in the dash.

B
KillerB is offline   Reply With Quote
Old 03-01-2008, 04:19 PM   #3
Rivieraracing
Full Access Member
 
Join Date: Feb 2008
Location: Oregon
Posts: 277
Rivieraracing is on a distinguished road
Default

Also, do you have an alarm, a bad install can really cause a big problem!!
Rivieraracing is offline   Reply With Quote
Old 03-01-2008, 06:33 PM   #4
Botches
Tahoeforum Apprentice Member
 
Botches's Avatar
 
Join Date: Feb 2008
Location: Arkansas
Posts: 18
Botches is on a distinguished road
Default

no aftermarket alarm. the lights stay on all the, time they just seems to lose some of there brightness real quick back and forth. could the battry be getting weak?
Botches is offline   Reply With Quote
Old 03-01-2008, 06:35 PM   #5
Botches
Tahoeforum Apprentice Member
 
Botches's Avatar
 
Join Date: Feb 2008
Location: Arkansas
Posts: 18
Botches is on a distinguished road
Default

as far as the dimmer switch goes..... anyone ever have any experience with a bad one? I do remember it feeling a little warm one time.
Botches is offline   Reply With Quote
Old 03-01-2008, 07:25 PM   #6
Rivieraracing
Full Access Member
 
Join Date: Feb 2008
Location: Oregon
Posts: 277
Rivieraracing is on a distinguished road
Default

When the light flicker back and forth like you are saying, is the truck on?
Rivieraracing is offline   Reply With Quote
Old 03-01-2008, 07:31 PM   #7
Botches
Tahoeforum Apprentice Member
 
Botches's Avatar
 
Join Date: Feb 2008
Location: Arkansas
Posts: 18
Botches is on a distinguished road
Default

yes
Botches is offline   Reply With Quote
Old 03-01-2008, 09:31 PM   #8
Rivieraracing
Full Access Member
 
Join Date: Feb 2008
Location: Oregon
Posts: 277
Rivieraracing is on a distinguished road
Default

Might be a weak battery making the alternator kick on more often to keep up with the lights. Is your idle a little inconsistant when the problem happens? Might be a dirty throttle body if idle is kinda rough, I had the same problem and cleaned my throttle body and it fixed it.
Rivieraracing is offline   Reply With Quote
Old 03-01-2008, 10:31 PM   #9
WrenchGuy
Full Access Member
 
WrenchGuy's Avatar
 
Join Date: Nov 2007
Posts: 435
WrenchGuy is on a distinguished road
Default

Weak battery most likely. Just get a deep cycle and be done. Mine still does it with a 300 amp alt. Its basically a Alt indicator right now. I'm not happy so I'm getting 4 Dekas. Am I the only one with crazy dimming going into 4 wheel?
WrenchGuy is offline   Reply With Quote
Old 03-01-2008, 10:38 PM   #10
ugachs24
Full Access Member
 
ugachs24's Avatar
 
Join Date: Jan 2008
Location: Roswell, Georgia / Clearwater, Florida
Posts: 635
ugachs24 is on a distinguished road
Default


Register to remove these ads. It's free!
I noticed that mine does it when I hit a big bump or jerk the wheel is that normal?
ugachs24 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 11:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum