Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 05-11-2008, 04:07 PM   #1
Mr45
Full Access Member
 
Mr45's Avatar
 
Join Date: Apr 2008
Location: Florida
Age: 35
Posts: 56
Mr45 is on a distinguished road
Default ABS and Brake light on


Register to remove these ads. It's free!
Noticed on two occasions last week, that the left front brake was acting weird when I came to a stop; almost like the ABS was messing with it.

Now, intermittently, I get the ABS and Brake warning light on startup, other times I don't.

Is the ABS sensor going bad? Are they tough to change out, and how much are they?
Mr45 is offline   Reply With Quote
Old 05-12-2008, 01:13 PM   #2
Mr45
Full Access Member
 
Mr45's Avatar
 
Join Date: Apr 2008
Location: Florida
Age: 35
Posts: 56
Mr45 is on a distinguished road
Default

Nobody?
Mr45 is offline   Reply With Quote
Old 05-12-2008, 08:38 PM   #3
XcesiveSlyd
Tahoeforum Noob
 
XcesiveSlyd's Avatar
 
Join Date: Mar 2008
Posts: 3
XcesiveSlyd is on a distinguished road
Default

Search for it. I searched google. I also had the ABS prematurely activating. It was a sticking caliper the first time. The second was because I wheel a lot the sensor had some grime/rust/dirt on it and it needed to be cleaned.
XcesiveSlyd is offline   Reply With Quote
Old 05-15-2008, 08:51 AM   #4
tspain
Full Access Member
 
Join Date: Apr 2008
Location: Memphis, TN
Posts: 57
tspain is on a distinguished road
Default

Also, check to make sure the hub bearing isn't going out. (Excessive slack back and forth) They are bad about getting to much slack and having to much play causing a clearance issue between the sensor and reluctor ring inside the hub.
tspain is offline   Reply With Quote
Old 05-15-2008, 09:00 AM   #5
greengumby
Full Access Member
 
greengumby's Avatar
 
Join Date: Mar 2007
Location: Joysey City Newjoysey
Posts: 558
greengumby is on a distinguished road
Default

Quote:
Originally Posted by tspain View Post
Also, check to make sure the hub bearing isn't going out. (Excessive slack back and forth) They are bad about getting to much slack and having to much play causing a clearance issue between the sensor and reluctor ring inside the hub.
X2.... and also Was a physical inspection done yet? i see alot of problems can be solved just by taking a look under and seeing...my abs wire was broken and had to replace the entire unit ..one piece
greengumby is offline   Reply With Quote
Old 05-22-2008, 04:19 PM   #6
Mr45
Full Access Member
 
Mr45's Avatar
 
Join Date: Apr 2008
Location: Florida
Age: 35
Posts: 56
Mr45 is on a distinguished road
Default

Well, we read out the error code, and it's the EBCM unit itself that's going bad.
Dammit.
Mr45 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum