Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


General Tahoe/Yukon/Escalade Discussion Forum General Tahoe/Yukon/Escalade Discussion Forum



Reply
 
Thread Tools Display Modes
Old 09-25-2006, 08:09 PM   #1
etiger
Tahoeforum Noob
 
Join Date: Sep 2006
Age: 35
Posts: 3
etiger is on a distinguished road
Default 4wd Switch Problem


Register to remove these ads. It's free!
Alright, my 4wd switch has been acting weird; it will randomly light up 4wd H and then even go into Neutral although it doesn't actually change into any of those. It will just happen as I am driving down the road. Alot of times the service 4wd light will come on.

So I was driving home today and I noticed that it had put me in 4wd Auto. So I hit the 2wd light and it switched it back. A few miles down the road it turned it into neutral. The light did not change, but it actually put the car in neutral (i.e. when I hit the gas it just reves the engine). I pulled over and tried to put the car in park but it stayed in neutral and the car starts rolling. So I hit the auto button and everything was ok. So I went and bought a new switch since I heard that a bunch of people have had issues with the light. So I switch it out and it is still acting up. Now, unless I leave the car in 4wd auto it will kick the trans into neutral. Also, if I try to change into 4wd L it makes 2 or three very loud clicking sounds and will not go into it.

Any ideas???? Please help.
etiger is offline   Reply With Quote
Old 10-04-2006, 10:17 PM   #2
Brisk
Tahoeforum Noob
 
Join Date: Aug 2006
Location: Castle Rock, CO
Age: 29
Posts: 11
Brisk is on a distinguished road
Default

maybe a problem with the motor on the T-Case or the servo that controls it
Brisk is offline   Reply With Quote
Old 10-03-2007, 05:38 PM   #3
mtodd54
Tahoeforum Noob
 
Join Date: Oct 2007
Posts: 4
mtodd54 is on a distinguished road
Default

definitely the Transfer Case Motor... $815 at the dealer. ouch! 55k miles and less than 2 years old. Between this and the Intermediate Steering Shafts I've had replaced, I hate to say it but I may go Japanese next time.

I hate to support another country but I don't feel like GM is concerned about the consumer.
mtodd54 is offline   Reply With Quote
Old 10-11-2007, 10:18 PM   #4
cafishel
Tahoeforum Noob
 
cafishel's Avatar
 
Join Date: Oct 2007
Location: Washington
Posts: 5
cafishel is on a distinguished road
Default 4x4 SWITCH

The woman I bought my rig from said she had a problem with the 4x4 SWITCH & had it replaced under warranty. Don't think the rig ever ACTUALLY changed gears though... don't think it went to that extreme.
cafishel is offline   Reply With Quote
Old 09-27-2012, 03:20 PM   #5
medic18
Tahoeforum Newcomer
 
Join Date: Sep 2012
Posts: 1
medic18 is on a distinguished road
Default

I have a similar, less severe problem with my 04 Tahoe Z71. My transfer case will stay in its gear until the truck is turned off. Once you turn the key to turn it back on, it seems to randomly choose which gear to put it in, even 4lo. It will always move back to to 2hi. I've replaced the 4wd actuator with no luck. Thinking it could be the switches or someone mentioned it possibly being a body control module issue. Any input? thanks.
medic18 is offline   Reply With Quote
Old 11-10-2012, 08:34 PM   #6
theclimberjoe
Tahoeforum Newcomer
 
Join Date: Nov 2012
Posts: 2
theclimberjoe is on a distinguished road
Default Same problem on 04 tahoe

Im having the exact same problem, when i am driving down the road in 2wd it seems to kick out of gear but i can put it into 4w auto and it will work fine. Been looking around to see what the issue may be. Any ideas would be greatly appreciated.
theclimberjoe is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum