A solution to brake lights not working or works sporadically

Discussion in 'General Tahoe/Yukon Discussion Forum' started by Conley79, Jun 28, 2017.

  1. Conley79

    Conley79 New Member

    Messages:
    11
    Likes Received:
    1
    Joined:
    Mar 10, 2016
    Location:
    Tulsa, ok
    Just figured out a issue that alot of Tahoe's have with the brake lights not working when the pedal is fully pressed and only work when pressed lightly. After searching everywhere on the web for days and days nobody seemed to know how to fix this issue but alot of people had the same problem. I finally found one guy that figures it out. It turned out to be a wire harness that goes to the brake light switch. The 3 wires were severed on the harness. You have to be a contortionist to get to it though. It's under the dash on top of the steering column. You unplug it from the brake switch and then unplug the harness and take it out to splice the wires back or you could try and find the harness. I love sharing knowledge that I learned and I'm passing it on to anyone with this same problem I hope I can help some frustrated people cause I know I was frustrated trying to figure out what the problem was. Thanks to the guy that shared his knowledge to help me greatly appreciated!
     
    DeAnna Thomas likes this.
  2. DeAnna Thomas

    DeAnna Thomas New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Feb 1, 2020
     
  3. DeAnna Thomas

    DeAnna Thomas New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Feb 1, 2020
    Im having an issue with my headlights going off if my tilt steering is set 'normal', but I put the tilt all the way up, they come back on? Im guessing pinched wire. The previous owner tried to hook up a radio and the spahgettied wires were everywhere. And when I got that mess out of there, my brake lights don't work now? Very frustrating! Any suggestions? And thanks for your post.