Fast Idle in Drive

Jamesdali

New Member
Joined
Sep 6, 2019
Messages
3
Reaction score
0
Hello all,

I have a 99 Chevy Tahoe with the 350 Vortec.

My problem is that I can do about 25 in Drive with out hitting the accelerator.
The truck can be either Hot or Cold. After start up, either Drive or Reverse the truck will rev to about 1K and wants to take off. I have to really mash on the breaks to control it. I can put the truck in N and the RPMS will be normal/do not surge.

I did a vacuum leak test and could not find any. I have normal 600-500 idle at start up. It doesn't show typical signs of a vacuum leak.
No CEL on either.

Any input would be great. :happy160:
 

SARNCAN

New Member
Joined
Nov 7, 2018
Messages
25
Reaction score
0
Hello all,

I have a 99 Chevy Tahoe with the 350 Vortec.

My problem is that I can do about 25 in Drive with out hitting the accelerator.
The truck can be either Hot or Cold. After start up, either Drive or Reverse the truck will rev to about 1K and wants to take off. I have to really mash on the breaks to control it. I can put the truck in N and the RPMS will be normal/do not surge.

I did a vacuum leak test and could not find any. I have normal 600-500 idle at start up. It doesn't show typical signs of a vacuum leak.
No CEL on either.

Any input would be great. :happy160:


I would go with throttle body cleaning.
If that doesn’t solve the problem, then that needs more investigations!
 

Jamesdali

New Member
Joined
Sep 6, 2019
Messages
3
Reaction score
0
I would go with throttle body cleaning.
If that doesn’t solve the problem, then that needs more investigations!

She looks pretty clean but i did not remove it. Ill give it ago. Its free and easy
 
Top