2002 Tahoe with 228k low oil pressure...

Kevin Bolkovatz

New Member
Joined
Nov 17, 2019
Messages
1
Reaction score
0
Hello,

I have a 2002 Tahoe with 228k miles on it. recently the oil pressure guage started to go low and the oil pressure low light came on. It now consistently hangs at about the second tick mark. When I rev the engine it goes up a little but at idle it almost goes to red. There is enough oil in it. The oil pressure sensor was replaced about 4 months ago. With this many miles should I consider replacing the engine instead of doing all the work to replace the oil pump and timing chain...? Thoughts?
 

Nate K

New Member
Joined
Jan 1, 2019
Messages
3
Reaction score
0
I'm having the same issue on my 2010. I'm thinking about replacing the wiring pigtail that connects to the sending unit.
 

Keygun

New Member
Joined
Jan 25, 2020
Messages
3
Reaction score
0
Hello,

I have a 2002 Tahoe with 228k miles on it. recently the oil pressure guage started to go low and the oil pressure low light came on. It now consistently hangs at about the second tick mark. When I rev the engine it goes up a little but at idle it almost goes to red. There is enough oil in it. The oil pressure sensor was replaced about 4 months ago. With this many miles should I consider replacing the engine instead of doing all the work to replace the oil pump and timing chain...? Thoughts?

I replaced the sending tube o ring inside oil pan. Worked amazingly
 

Goodoldchevy

New Member
Joined
Jul 27, 2020
Messages
6
Reaction score
0
Location
USA
+1 on the O-ring and I'm have a sneaking suspicion it could eat your rings if left too long...don't ask...LOL
 

PNW NBS Z71

Member
Supporting Member
Joined
Oct 9, 2020
Messages
48
Reaction score
2
Location
Eugene, Oregon
Yes, my first thought is the oil pump pickup oil ring. On the newer NNBS rigs and maybe even the newer NBS rigs there is a screen filter for the oil sender that should be replaced. Do yourself a big favor and use quality GM parts, especially for the sensor itself.
 
Top